Skip to end of metadata
Go to start of metadata

ArionFX is compatible with all Photoshop versions from CS3 to CC 2015.5.

ArionFX requires a 64-bit Photoshop installation and a 64-bit capable CPU.

ArionFX does not have any specific requirements regarding the display adapter or its drivers.

There is no minimum CPU speed or RAM for ArionFX to work, however certain effects can be computationally intensive and we recommend the following minimum hardware for a better experience:

  • 4 cores CPU or better
  • 8 Gb RAM or better
  • 1920x1080 screen resolution or better
  • Windows 7 64-bit or better

 

 

  • No labels